Filter by formula in Airtable


#1

Hello,
I’m following the example here: http://support.intuilab.com/kb/how-to/work-with-intuiface-airtable and trying to get my search / filter to work on an airtable. When I click my “filter” button I’m telling the airtable database to only show results for “tony” on release {Contact}=“tony”… but nothing happens. I was able to call a refresh on it and that works so I do at least have some communication happening.


#2

Hi,

You should start a discussion with the support team and share your XP with xp-for-support (at) intuilab (dot) com.
They’ll investigate this for you, as from what I see on your screenshot, it should work.

Seb


#3

Thanks @Seb
In a support ticket, he pointed out that I needed to switch to the query instead of header request in API Explorer. My careless mistake. That worked and I can now search.

My next question when searching Airtable is I’m afraid I won’t be able to have it update as the user types, so as they start typing the name david, they get a list with each keystroke of all the davids as well as the daniels and darcys until they type the first 3rd letter obviously, then it filters more. I was using the “text is updated” trigger to get this behavior when working with a local excel file and had it working, but could anyone tell me if this is even possible with Airtable? I read about the data limits as well and am guessing each keytroke counts a request, so if someone types a name fast enough it would return errors. (limited to 5 requests per second.)

The way filterByFormula seems to work now, is that the whole thing “first AND last name for example” has to be input then the request is made in order to return a result. I tried creating parameters like “view” and “filter” but that did nothing. Was looking in Airtable’s API documentation but maybe this is just not possible to update the search per keystroke?

Thanks,
Carson


#4

Hi @carson,

When you create a web api Interface Asset using API Explorer, it automatically includes a delay of 250ms between each request. You can see details in this documentation article.
This means you won’t get more than 4 requests / seconds even if you use the Text is updated trigger to change your filter parameter.

To filter “per keystroke”, you can use the method described here to search for a substring of your column values.

I hope this helps :slight_smile:

Seb


#5

@seb Thanks so much for your patience and pointing me to the exact info I needed! I have it working as expected now.